Start a new topic
Implemented

Visual Composer

Visual Composer 4.11 is required to work correctly with WP 4.5.1.


But it won't upgrade automatically like all other plugins.


Solution:  You need to delete the plugin first (if it's corrupt in plugins, you can rename/delete the folder "js-composer" from the plugins folder for your theme using your hosts file manager).  Then from the plugins window, select "begin installing required plugins" for this theme.


Problem solved. Although I think it sometimes kills some of the background images and colors and you might need to reset them.


Hi,


Make sure that you are using the latest version of the theme as well. 

V.2.7 – JUNE 20TH 2016


Updated Visual Composer to version 4.12

Updated Revolution Slider to version 5.2.5.4

Refactored and fixed the Twitter Widget. You will have to set your own Twitter API keys to make the twitter feed working again.

Refactored the demo importer with Unyson Framework for better performance

Updated TGMPA

Fixed an issue with WP 4.5.x where custom-style is not loaded when permalinks are set to “base”

Fixed issue with wp_enqueue

Fixed parallax issue

Removed php warning and notice




If you only update VC and NOT the theme, it wont work. You need to update both. So please, update your theme. When the new theme is installed, you can delete the plugin VC, then go to Appearance > Install Plugins, and install the new VC plugin from there.


If it still doesnt work, please open a support ticket and our team will assist you.


Thanks,


Maxime

i try to solve problem two weeks. that is terrible. i have official theme and purchased VC but it still doesnt work. i tried everything what is writen here. plugin instaled by LUSH is defekt and cant be used, also original VC from WPbakery is not possible to use. 

Ive updated my theme recently and now VC doesnt work at all


Hello Danielle,


Does your webdesign has used the best practice and used the Child Theme ? If so, you will be able to update without issues.


Otherwise, you will always be stuck with the old version unfortunately.

You might try to buy yourself a VC licence, but i cant say that it will works. we made several change since October 2015....


thanks,

Maxime

Hello Maxine,


I am using the LUSH theme purchased Oct 2015.  The site is currently at Wordpress 4.6, but is still at VC 4.5.3, which is not working.  I understand the compatibility issue and that I need to update my VC.  I read here that you recommend updating the theme, which will automatically update the VC.  Problem for me is that I worked with a web designer that add quite a bit of custom CSS and backend server coding to fit my needs, and fear that this update will override these customizations.  I currently do not have the resources to recover these customizations should they be lost.  Is there any other options for me instead of updating the entire team? Would purchasing VC separately and installing it into my LUSH theme fix the problem?

Thanks,

Danielle 

@Andrea Fingolo: Go to Wp-Admin > Plugins, then delete Visual Composer if it shows up. Then go to WP-Admin > Appearance > Install Plugin and install + activate your plugin there.



If you still have issue, open a support ticket here: http://support.irontemplates.com/support/tickets/new

and our support team will assist you.



Thanks,

Maxime

** UPDATE FROM AUTHOR **


You don't have to "activate" Visual Composer with a licence key.  Even if Visual Composer ask you to "activate" it, it's not required and Visual Composer will works without the licence key.


The licence key is used if you want to subscribe to automatic updates of the plugin. As a theme author, we have to make sure that every time a new version of Visual Composer is released, the new version is compatible with your theme. The latest compatible version of VC is always provided (and packaged) within your theme. So the best way to update VC is to first UPDATE your theme. Once it's updated, go to WP-Admin > Appearance > Install Plugin and you will see if a new compatible version is available to be updated. If so, click update.



Hi, I bought Croma yesterday. Can't install Visual Composer, I tried deleting the file in ftp but it didn't work. A fast solution please?

Visual composer is installed but I cannnot seem to activate it.


Is it necessary to buy a license for visual composer after buying the lush theme in order to edit the layout?


If you have issue with Visual Composer that does not work, please, update your theme. We updated Visual Composer in our last package. 

Once the theme is updated, you can delete Visual Composer plugin then go to Wp-Admin > Appearance > Install Plugins, and install Visual Composer again.


Thanks,

Maxime

Thank you very much.

4.8.1 stopped working for me too. That's why I had to figure out how to get the upgrade through Lush. I think you can also check the Envato Update tool to get the upgrade that way as well. Can't remember.

Hi Guys, that does not appear to work for me. I deleted the plugin from my wordpress site, but afterwards I did not get the option "beginn installing required plugins". If I want to work with visual composer and try to add an element, the plugin seems to work and work and work, but I cannot go on and finish my work. I use version 4.8.1 on the current WP-version.


Thank You. 

Login or Signup to post a comment